Symptoms
The disk usage displayed in cPanel / Email Accounts does not reflect the correct amount after messages are removed from an email account.
Cause
The Email Accounts interface reports the usage from the local dovecot-quota file. While the disk usage and RoundCube may show the correct usage, this can lag behind if the quota file has not been rebuilt. This normally only triggers when a new message is received, or an IMAP/POP3 connection is made.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-50872.
Resolution
To manually rebuild the quota for a user, please follow these steps:
-
First, remove the Dovecot indexes for the user:
/scripts/remove_dovecot_index_files --user cpuser
-
Next, regenerate the
maildirsizefor all users under the account:/scripts/generate_maildirsize --confirm --allaccounts cpuser
- Finally, send an email from the email address that you want to update the quota for.
Note: Replace cpuser with the cPanel username in each of the above commands.